Du bist nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Insektenfotos.de-Forum. Falls dies dein erster Besuch auf dieser Seite ist, lies bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

  • »Jörg Pageler« ist der Autor dieses Themas

Beiträge: 3 523

Registrierungsdatum: 11. Oktober 2009

Wohnort: Oldenburg i.O.

  • Private Nachricht senden

1

Montag, 28. Juni 2010, 22:27

Irgendwas läuft schief

Moin Jürgen,

ist bei den Kalamitäten von gestern eventuell doch mehr schiefgegangen? Ich habe gerade zufällig nach meinem Beitrag "Mein erster Bachhaft" gesehen und dort die Bilder von Evas Maulwurfsgrille vorgefunden (?)

Viele Grüße,
Jörg

Beiträge: 62 407

Registrierungsdatum: 8. Juli 2005

Wohnort: 33829 Borgholzhausen/Ostwestfalen (MTB 3815), ca. 120 m NN

  • Private Nachricht senden

2

Montag, 28. Juni 2010, 23:48

Bilderverlinkung, war: Irgendwas läuft schief

Hallo, Jörg!

Zitat

Original von Jörg Pageler
ist bei den Kalamitäten von gestern eventuell doch mehr schiefgegangen? Ich habe gerade zufällig nach meinem Beitrag "Mein erster Bachhaft" gesehen und dort die Bilder von Evas Maulwurfsgrille vorgefunden (?)


Hmm... 8o Da muß beim Reindexieren der Bilder was durcheinandergekommen sein. Die Anhänge und zugehörigen Thumbnails (mittlerweile 188.901 Dateien zum Zeitpunkt der letzten Sicherung) liegen ja alle in einem einzigen Verzeichnis und tragen die Namen 'attachment-1.jpg' bis (momentan) 'attachment-95708.jpg' bzw. 'thumbnail-1.jpg' bis 'thumbnail-95708.jpg'.

Du wirst verstehen, daß die manuell nicht mehr zuordbar sind, ich auch nicht alle Beiträge zur Prüfung durchgehen kann, und glaube, auch die Forensoftware ist nicht wirklich mit der Vorstellung, daß mal so viele Anhänge in einem einzigen Forum verwaltet werden müßten, entwickelt worden (sowas wie Unterordner für die Unterforen/Kategorien wären vielleicht wünschenwert, aber auch das würde die Zahl der Dateien pro Verzeichnis höchstens von einer fünfstelligen auf eine vierstellige Zahl reduzieren...).

Ich kann deshalb nur anbieten, wenn jemand bemerkt, daß in seinem nicht mehr selber editierbaren Beitrag die falschen Fotos verlinkt sind, mir diese per Mail zuzusenden. Ich tausche die falschen dann aus.


Viele Grüße, Jürgen
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Borgholzhausen, Deutschland
Typische Habitate, in denen ich unterwegs bin.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=





  • »Jörg Pageler« ist der Autor dieses Themas

Beiträge: 3 523

Registrierungsdatum: 11. Oktober 2009

Wohnort: Oldenburg i.O.

  • Private Nachricht senden

3

Dienstag, 29. Juni 2010, 11:53

RE: Bilderverlinkung, war: Irgendwas läuft schief

Moin Jürgen,

dann hoffen wir mal, daß nicht noch mehr Fotos vertauscht wurden. Beim Bachhaft fällt natürlich sofort auf, daß da was nicht stimmt, aber es wäre ja wirklich übel, wenn man bei seinen Bestimmungsversuchen falsche Bilder zu Rate zieht.

Ich habe gerade in meinem "Kontrollzentrum" unter "Dateianhänge" nachgesehen, und da ist mein Bachhaft auch nicht mehr zu finden. Stattdessen die zwei Maulfwurfsgrillenbilder von Eva (die allerdings den Namen meiner Bilder tragen). Sehr mysteriös.

Viele Grüße,
Jörg

Beiträge: 62 407

Registrierungsdatum: 8. Juli 2005

Wohnort: 33829 Borgholzhausen/Ostwestfalen (MTB 3815), ca. 120 m NN

  • Private Nachricht senden

4

Dienstag, 29. Juni 2010, 22:39

RE: Bilderverlinkung, war: Irgendwas läuft schief

Hallo, Jörg!

Zitat

Original von Jörg Pageler
Ich habe gerade in meinem "Kontrollzentrum" unter "Dateianhänge" nachgesehen, und da ist mein Bachhaft auch nicht mehr zu finden. Stattdessen die zwei Maulfwurfsgrillenbilder von Eva (die allerdings den Namen meiner Bilder tragen). Sehr mysteriös.


Eigentlich nicht. Die Namen stehen nur in der Forendatenbank. Da steht dann z.B. (vereinfacht ausgedrückt): "Bachhaft.jpg"=attachment-94827.jpg. Was dann aber konkret für ein Bild unter attachment-94827.jpg im Attachmentverzeichnis auf dem Server liegt, weiß die Forensoftware nicht. Die kann ja nicht erkennen, ob da ein Bachhaft oder eine Maulswurfsgrille abgebildet ist (wäre schön, wenn es schon so schlaue Software gäbe ;), dann könnten sich die Experten zur Ruhe setzen).

Wenn die Zuordnung angezeigter Name <-> echter Dateiname (attachment-...jpg) also einmal durcheinandergeraten ist und auf eine falsche Datei verweist, dann wird auch überall dieses falsche Bild angezeigt.


Viele Grüße, Jürgen
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Borgholzhausen, Deutschland
Typische Habitate, in denen ich unterwegs bin.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=





  • »Jörg Pageler« ist der Autor dieses Themas

Beiträge: 3 523

Registrierungsdatum: 11. Oktober 2009

Wohnort: Oldenburg i.O.

  • Private Nachricht senden

5

Mittwoch, 11. Mai 2011, 20:34

RE: Bilderverlinkung, war: Irgendwas läuft schief

Moin Jürgen,

ich bin gerade bei der Forensuche nach Oxyna auf diesen Beitrag von Just gestoßen und mußte feststellen, daß sich da auch inzwischen Evas Maulwurfsgrille eingeschlichen hat X(

Viele Grüße,
Jörg
»Jörg Pageler« hat folgendes Bild angehängt:
  • Unbenannt.jpg

Beiträge: 11 147

Registrierungsdatum: 6. Juni 2006

Wohnort: Hamburg

  • Private Nachricht senden

6

Mittwoch, 11. Mai 2011, 20:38

8o 8o 8oDas Forum ist also von einem Maulwurf unterwandert 8o :D
Liebe Grüße

Kirsten Eta

Beiträge: 62 407

Registrierungsdatum: 8. Juli 2005

Wohnort: 33829 Borgholzhausen/Ostwestfalen (MTB 3815), ca. 120 m NN

  • Private Nachricht senden

7

Mittwoch, 11. Mai 2011, 21:29

RE: Bilderverlinkung, war: Irgendwas läuft schief

Hallo, Jörg!

Zitat

Original von Jörg Pageler
ich bin gerade bei der Forensuche nach Oxyna auf diesen Beitrag von Just gestoßen und mußte feststellen, daß sich da auch inzwischen Evas Maulwurfsgrille eingeschlichen hat


Hmm... Keine Ahnung :(. Mehr als "Da muß wohl irgendwas durcheinandergekommen sein" kann ich spontan auch nicht dazu sagen. Habe eben nochmal das Bereinigungsskript, welches falsch bzw. unzugeordnete Attachments löscht, laufen lassen. Das hat auch einige entfernt, aber offenbar nicht diese...

Ich kann im Prinzip nur die Grillenfotos löschen und Just anbieten (Just, liest du?), mir seine Bohrfliegenfotos zu schicken, dann hänge ich sie neu an.


Viele Grüße, Jürgen
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Borgholzhausen, Deutschland
Typische Habitate, in denen ich unterwegs bin.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=





Beiträge: 9 464

Registrierungsdatum: 5. Oktober 2006

Wohnort: Niederlande

  • Private Nachricht senden

8

Donnerstag, 12. Mai 2011, 13:58

RE: Bilderverlinkung, war: Irgendwas läuft schief

Moin,

Sieht für mich - auch schon wegen des halben Bildes - irgendwie aus nach ein typischer Festplatten-Hick-Up - wo entweder durch umkippen von ein bit (hardware) oder Software/Firmware-Crash eine Indizierung durch ein ander gekommen ist (falscher Festplattensektor oder logisches Block wird adressiert). Das ist zwar peinlich, eben weil sowas dann unaufgemerckt auch in den nächsten Backups rein rollt und schon schnell nicht mehr mit Backup zu reparieren ist, aber ist wohl eher ein "einmaliges" Ereigniss und deutet nicht notwendigerweise auf strukturelle fehlhafte Verarbeitung. Ich würde mal denken das die weitaus praktikabelste Lössung wirklich ist um Just um neue Bilder zu bitten ...

Meine 2ct, Arp

P.S. Achtung: Beim "lösschen" der Grillenfoto's "von Just" besteht die Chanze das Du damit auch die Grillenfoto's von Eva lösschst (oder jedenfalls den Festplattenplatz wieder freigibst und diese somit später überschrieben werden können. Am besten also erst die Bilder von Eva abspeichern, dann beide (von Just und Eva) - bzw alle (Bachhaft von Jörg oder auch andere??) lösschen, und dann erst neu aufspielen.
P.P.S. Mit Lösschen ist hier allerdings das Lösschen der Dateien auf den Server gemeint - nicht das entferner der Attachments aus den Beiträge ... man könnte vieleicht noch über den Beitragsnummern (Post ID) finden welche Beiträge (und somit Anhänge) vorher und nachher gekommen sind und so die alte Attachmentnummern wieder ableiten. Am besten für alle diese die Bilder abspeichern, dateien Lösschen und dann neu aufspielen mit den selben/alten Dateinnamen. Dann liegen die auf einen anderen (virtuellen) Festplattenplatz und in sofern das Dateisystem der (virtuellen) Festplatte durcheinander gekommen war und zwei Dateinamen fälschlicherweise auf den gleichen Festplattenblock zugegriffen haben sollte das dann wieder ins grüne sein.

Beiträge: 62 407

Registrierungsdatum: 8. Juli 2005

Wohnort: 33829 Borgholzhausen/Ostwestfalen (MTB 3815), ca. 120 m NN

  • Private Nachricht senden

9

Donnerstag, 12. Mai 2011, 20:12

RE: Bilderverlinkung, war: Irgendwas läuft schief

Hallo, Arp!

Zitat

Original von Arp
P.P.S. Mit Lösschen ist hier allerdings das Lösschen der Dateien auf den Server gemeint - nicht das entferner der Attachments aus den Beiträge ... man könnte vieleicht noch über den Beitragsnummern (Post ID) finden welche Beiträge (und somit Anhänge) vorher und nachher gekommen sind und so die alte Attachmentnummern wieder ableiten.


Das ganze dürfte allerdings aus rein praktischen Gründen etwas schwierig werden, denn zur Zeit liegen im Attachment-Verzeichnis auf dem Server (und im Backup hier auf meinem PC) 232.781 (knapp eine Viertelmillion!) Dateien. Auf sowas ist wohl weder die Forensoftware eingerichtet (ich hatte damals versucht, mittels deren Controlpanel-Funktion die Anhänge neu zu indizieren, doch das lief die ganze Nacht durch und brach dann doch irgendwann ab) - sonst wäre es sicher nicht konzeptionell vorgesehen, alle Attachments+Vorschaubilder in einem Ordner zu lagern -, noch kommt damit das FTP-Protokoll klar. Alle getesteten FTP-Programme mit allen mögliichen ausprobierten Einstellungen brechen schon beim Einlesen des Inhaltsverzeichnisses ab ("Timeout", "Connection lost" o.ä., auch serverseitiges Rumprobieren an den Settings half nichts).

Seit dem Überschreiten einer bestimmten Dateianzahl irgendwann letztes Jahr kriege ich hier überhaupt noch ein Backup des Attachment-Directorys mittels einiger Tricks hin (FTP-Zugriff über HTTP-Proxy mit Kerio Winroute, welches zumindest beim zweiten Versuch das Inhaltsverzeichnis "packt", weil es abgebrochene Versuche in Temp-Dateien zwischenspeichert).


Viele Grüße, Jürgen
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Borgholzhausen, Deutschland
Typische Habitate, in denen ich unterwegs bin.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=





Beiträge: 9 464

Registrierungsdatum: 5. Oktober 2006

Wohnort: Niederlande

  • Private Nachricht senden

10

Donnerstag, 12. Mai 2011, 21:53

RE: Bilderverlinkung, war: Irgendwas läuft schief

Hi Jürgen,

Du kennst doch von DOS-Zeiten bestimmt den good old command line noch? Das ist unter Linux auf'm Server nicht viel anders. Einfach über 'nen ssh reingehen, ein (Unter?)Verzeichnis für das Zeitweilige parken der Problemdateien anlegen, hinein kopieren, originale lösschen, kopien zurück kopieren, zeitweilige Verzeichnis aufräumen, feddig. Du packst das ;)

Lieber Gruss, Arp

Das mit den FTP-Probleme und Backup ist aber schon peinlich - da müsste man sich was besseres für einfallen lassen .... ist aber ein anderes Problem.

Beiträge: 62 407

Registrierungsdatum: 8. Juli 2005

Wohnort: 33829 Borgholzhausen/Ostwestfalen (MTB 3815), ca. 120 m NN

  • Private Nachricht senden

11

Donnerstag, 12. Mai 2011, 23:35

RE: Bilderverlinkung, war: Irgendwas läuft schief

Hallo, Arp!

Zitat

Original von Arp
Du kennst doch von DOS-Zeiten bestimmt den good old command line noch? Das ist unter Linux auf'm Server nicht viel anders.


Ja, ich war schonmal mittels SSH an der Kommandozeile auf dem Server. Dabei fiel mir auf, daß ich wirklich überhaupt keine Ahnung von den Linux-Befehlen hatte. Ich konnte mir nichtmal einen Verzeichnisinhalt anzeigen lassen, weil ich das Äquivalent zum DIR-Befehl unter Unix nicht kannte... :rolleyes:
Da ich keine Lust zur Einarbeitung hatte (du kennst das ja mit der Zeit, Zeit, Zeit...), ist das dann der einzige Besuch geblieben. Die Plesk-Oberfläche hat ja auch ansonsten gereicht, und zum gelegentlichen Löschen überbordender Logfiles und Editieren von /var/qmail/control/me (was mal nach Plesk-Updates nötig war) habe ich WinSCP benutzt.

Aber irgendwann werde ich mir das sicher nochmal ansehen...

Zitat

Das mit den FTP-Probleme und Backup ist aber schon peinlich - da müsste man sich was besseres für einfallen lassen .... ist aber ein anderes Problem.


Na ja, es funktioniert immerhin... Ich hatte damals auch diverse Verzeichnissynchronisierungstools ausprobiert, aber es war mit allen auf FTP basierenden dasselbe. WinRoute habe ich aber eh laufen, und das tägliche Backup des Attachment-Folders mache ich jetzt mit dem Total Commander. Die Forendatenbank wird automatisch gesichert und mir per FTP auf den PC geschickt.


Viele Grüße, Jürgen
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Borgholzhausen, Deutschland
Typische Habitate, in denen ich unterwegs bin.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=





Beiträge: 9 464

Registrierungsdatum: 5. Oktober 2006

Wohnort: Niederlande

  • Private Nachricht senden

12

Freitag, 13. Mai 2011, 00:30

RE: Bilderverlinkung, war: Irgendwas läuft schief

Zitat

Original von Jürgen Peters
und das tägliche Backup des Attachment-Folders mache ich jetzt mit dem Total Commander.
Der macht das ja bestimmt auch über FTP oder? Wenn der das packt, dann soltest Du doch auch mit dem einzelne Dateien verschieben/kopieren/lösschen können, oder hab ich da nun was falsch verstanden?

Beiträge: 62 407

Registrierungsdatum: 8. Juli 2005

Wohnort: 33829 Borgholzhausen/Ostwestfalen (MTB 3815), ca. 120 m NN

  • Private Nachricht senden

13

Freitag, 13. Mai 2011, 00:40

RE: Bilderverlinkung, war: Irgendwas läuft schief

Hallo, Arp!

Zitat

Original von Arp

Zitat

Original von Jürgen Peters
und das tägliche Backup des Attachment-Folders mache ich jetzt mit dem Total Commander.
Der macht das ja bestimmt auch über FTP oder?


Nur über den zwischengeschalteten HTTP-Proxy. Beim direkten Zugang per FTP hat er dieselben Probleme wie jeder andere FTP-Client auch.


Nachtrag:

Zitat

Wenn der das packt, dann soltest Du doch auch mit dem einzelne Dateien verschieben/kopieren/lösschen können, oder hab ich da nun was falsch verstanden?


Könnte sein. Ich verwende nur die "Verzeichnisse synchronisieren"-Funktion und vermeide es, direkt in das Verzeichnis zu gehen. Schon auf meinem PC dauert es eine Viertelstunde, den Ordner mit >270.000 Dateien einlesen und anzeigen zu lassen. Bei jedem Löschen, Kopieren o.ä. einzelner Dateien, bei einer Sortierung (nach Name, Datum o.ä.) macht er das neu.
Über die Internetverbindung mit FTP-/HTTP-Protokoll und Speichern des Directoryinhaltsverzeichnisses in Temp-Dateien dauert jede einzelne Aktion Stunden. Bei der Synchronisierung braucht wenigstens nichts angezeigt zu werden. Die stoße ich meistens nachts an, bevor ich ins Bett gehe.


Viele Grüße, Jürgen
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Borgholzhausen, Deutschland
Typische Habitate, in denen ich unterwegs bin.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=